Objects by Design Forums Here you can view your subscribed threads, work with private messages and edit your profile and preferences Registration is free! Calendar Find other members Frequently Asked Questions Search Home  
Objects by Design Forums : Powered by vBulletin version 2.3.5 Objects by Design Forums > Main Forums > UML Tools > Problems when exporting model using Rose and Unisys XMI - Please help
  Last Thread   Next Thread
Author
Thread Post New Thread    Post A Reply
Sunfire1
Junior Member

Registered: Mar 2004
Location:
Posts: 1

Problems when exporting model using Rose and Unisys XMI - Please help

Dear friends:

I exported a model using the Rational Rose and Unisys XMI
addin (XMI 1.1), the output XML file is quite weird. The problem is like this: I wrote a few words in the documentation field for each use case. In the output XML file, some of these words show as an attribute value in the <UML:TaggedValue> tag, but others show as a sub-element (i.e., <UML:TaggedValue.value> )
of this tag. This is not the case every time I export the
same model: sometimes when I export the model, all words appear in the attribute value of the <UML:TaggedValue> tag, which is the correct format I need. Does anybody know why this
happens and how I can fix it? Please see the result below. Thanks a lot.

Sincerely,

P.S.: It looks like I don't have this problem when exporting models using XMI 1.0.

<UML:TaggedValue xmi.id = 'XX.29.2256.7.2'
tag = 'documentation' modelElement = 'S.059.2256.07.4' >
<UML:TaggedValue.value>n: Integer, s Session, c: Card,
name: String;</UML:TaggedValue.value>
</UML:TaggedValue>
<UML:TaggedValue xmi.id = 'XX.29.2256.7.3'
tag = 'documentation' modelElement = 'S.059.2256.07.5' >
<UML:TaggedValue.value>s: Session, n: Integer, name:
String;</UML:TaggedValue.value>
</UML:TaggedValue>
<UML:TaggedValue xmi.id = 'XX.29.2256.7.4'
tag = 'documentation' modelElement = 'S.059.2256.07.6' >
<UML:TaggedValue.value>s: Session, c: Card; Pre: s.status
= ON;</UML:TaggedValue.value>
</UML:TaggedValue>
<UML:TaggedValue xmi.id = 'XX.29.2256.7.5'
tag = 'documentation' value = 's: Session; u: User'
modelElement = 'S.059.2256.07.7' />
<UML:TaggedValue xmi.id = 'XX.29.2256.7.6'
tag = 'documentation' modelElement = 'S.059.2256.07.8' >
<UML:TaggedValue.value>c: Card, pin: Integer, s:
Session;</UML:TaggedValue.value>
</UML:TaggedValue>
<UML:TaggedValue xmi.id = 'XX.29.2256.7.7'
tag = 'documentation' value = 'c: Card, s: Session,
amount: Integer, account_name: String;'
modelElement = 'S.059.2256.07.9' />

Report this post to a moderator | IP: Logged

Old Post 03-03-2004 02:59 PM
Sunfire1 is offline Click Here to See the Profile for Sunfire1 Click here to Send Sunfire1 a Private Message Find more posts by Sunfire1 Add Sunfire1 to your buddy list Edit/Delete Message Reply w/Quote
ddrillich
Junior Member

Registered: Jan 2004
Location:
Posts: 20

Sunfire1,

This XML document is not well formed – for one thing, it doesn’t have a root element.

Thanks,
Dan

Report this post to a moderator | IP: Logged

Old Post 03-04-2004 06:50 PM
ddrillich is offline Click Here to See the Profile for ddrillich Click here to Send ddrillich a Private Message Find more posts by ddrillich Add ddrillich to your buddy list Edit/Delete Message Reply w/Quote
All times are GMT. The time now is 04:28 AM. Post New Thread    Post A Reply
  Last Thread   Next Thread
Show Printable Version | Email this Page | Subscribe to this Thread

Forum Jump:
Rate This Thread:

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are ON
[IMG] code is OFF
 

< Contact Us - Objects by Design >

Powered by: vBulletin Version 2.3.5
Copyright ©2000 - 2017, Jelsoft Enterprises Limited.
Copyright ©1999-2005, Objects by Design, Inc.